Page 1 of 2

.NET Framework 4.0 problem (Solved) - No bridge func

PostPosted: July 3rd, 2010, 12:20 pm
by limbo
OK i'm back with a solution (based on Andrew's config file)

Andrew wrote:OK. I have an solution from MS Connect:
There's not much we can do now about the runtime activation implementation in 4.0. It may be possible to work around the Windows behavior with a hack but given where we are in the product cycle this is very unlikely to happen.
However, if you don't mind running LCD Smartie managed plugins in .NET 4.0, you can configure the app so by adding the following config file (named LCDSmartie.exe.config):
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0" />
</startup>
</configuration>




I altered a bit this file and finally all plugins are loaded with out any problem... at least on my system (need more people to test it).
So LCDSmartie.exe.config file should contain the following:
Code: Select all
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0" />
</startup>
 <runtime>
    <loadFromRemoteSources enabled="true" />
  </runtime>
</configuration>


this file should be placed in LCD Smartie directory.

Re: .NET Framework 4.0 problem

PostPosted: July 3rd, 2010, 12:30 pm
by twhyman
Hi,

Thanks for the .config file it's working now on Windows 7 x64 :D

No more "Bridge Func" or exceptions.

Thank you :D

Re: .NET Framework 4.0 problem

PostPosted: July 6th, 2010, 1:25 pm
by stephenord
Hi,

Me too, All now working now on Windows 7 x64 again, had been wondering what had broken my setup!

No more "Bridge Func" or exceptions.

Thank you!

Re: .NET Framework 4.0 problem

PostPosted: July 12th, 2010, 4:11 pm
by usling
thank you!

Lcdsmartie now works again on my win7 64bit version. I have lots of plugins, all seem to work again.

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: July 26th, 2010, 9:23 am
by fb2805
Hello,

where do I copy the code? In the "LCDSmartie.cfg" or the "config.ini"?

Best regards,
fb2805

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: July 26th, 2010, 3:57 pm
by isacdan
limbo wrote:this file should be placed in LCD Smartie directory.

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: July 30th, 2010, 12:04 am
by Cnuut
Nice! works fine for me :)

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: August 4th, 2010, 8:19 am
by almamater
Thanks!!!! Works Perfect :D :D :D :D

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: August 17th, 2010, 11:04 pm
by DethMarine21
Thanks for the fast fix :D

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: August 30th, 2010, 3:58 am
by karicsek
Nagyon köszönöm. Így már ok.
Thanks.
Karicsek

Re: .NET Framework 4.0 problem (Solution Found) - No bridge func

PostPosted: October 13th, 2010, 10:36 am
by Wormi
Thx! Works for me too (Win7 64bit) :D

Re: .NET Framework 4.0 problem (Solved) - No bridge func

PostPosted: December 14th, 2010, 4:52 pm
by ssurgey
sorted my machine out as well, windows 7 X64

Re: .NET Framework 4.0 problem (Solved) - No bridge func

PostPosted: February 24th, 2011, 10:40 pm
by hirkkak
Thanks, finally is working.
Window 7 X64

Re: .NET Framework 4.0 problem (Solved) - No bridge func

PostPosted: March 2nd, 2011, 7:38 pm
by dustbuster
Maybe it sounds a little dumb but can you tell me how it suppose to be done?
This file is for download or I need to modify the old one (which one?)?
I just didn`t get it.

Regards

Re: .NET Framework 4.0 problem (Solved) - No bridge func

PostPosted: March 26th, 2011, 1:26 pm
by mister
dustbuster wrote:Maybe it sounds a little dumb but can you tell me how it suppose to be done?
This file is for download or I need to modify the old one (which one?)?
I just didn`t get it.

Regards


+1